ABPro 4.0.5 is required for Joomla 4. 
 

Features that not are coming over to Joomla 4:

  • Payment processors, other than PayPal.
  • Email Marketing (MailChimp, AcyMailing)

 

 

See ABPro 4.0.5 running under Joomla 4.0 -> here

 

 

Moving to Joomla 4 / ABPro 4.0.5

As table changes were required for Joomla 4, you cannot simply install ABPro 4.0.5 over top of 4.0.3, you need to:

  1. ABPro Backup under J3, ABPro 4.0.3
  2. Uninstall ABPro 4.0.3
  3. Upgrade J3 to J4
  4. Install ABPro 4.0.5
  5. Restore the backup from step 1 with ABPro Restore

 

 To move ABPro from a Joomla 3 site to a new Joomla 4 site see..https://appointmentbookingpro.com/migrate-to-a-new-server.html